Press "Enter" to skip to content

给thinkphp3.2用上composer

系统构建时使用的是 thinkphp3.2.3,当时的框架并没有使用 composer 作为包管理器,第三方包统一放到了 ThinkPHP/Library/Vendor 目录下面。
随着集成的第三方包越来越多,出现很多重复依赖的基础包,如: Guzzle 、console 等
所以记录下集成 compose r的过程,参照 packagist.org 实现

一、项目根目录添加 composer.json

{
  "require": {
    "php": ">=5.5",
    "aws/aws-sdk-php": "^3.90"
  }
}

二、安装 composer

官方说明,不再赘述

三、安装依赖

项目目录直接安装依赖包,自动生成 vendor 目录

composer install

四、引入自动加载

在原来的 thinphp 框架里 index.php 文件头部首行引入 vendor/autoload.php

<?php
// 增加自动加载
require './vendor/autoload.php';

if(version_compare(PHP_VERSION,'5.4.0','<'))  die('require PHP > 5.4.0 !');

define('APP_DEBUG', true);
define('APP_PATH', './Application/');
define('RUNTIME_PATH', './Runtime/');
define('COMMON_PATH','./Common/');
define('BUILD_DIR_SECURE', false);

require './ThinkPHP/ThinkPHP.php';

Be First to Comment

发表评论

电子邮件地址不会被公开。 必填项已用*标注

Captcha Code